Anidar funciones en Excel – Explicado

  1. Software
  2. Oficina de Microsoft
  3. Excel
  4. Anidando Funciones en Excel

Libro Relacionado

Por Ken Bluttman

Una función anidada está metida dentro de otra función de Excel como uno de sus argumentos. Las funciones de anidamiento le permiten obtener resultados que de otro modo le sería difícil obtener.

La siguiente figura muestra el precio de cierre diario de Standard & Poor’s 500 para el mes de septiembre de 2004. Un posible análisis es ver cuántas veces el precio de cierre fue más alto que el promedio del mes. Por lo tanto, es necesario calcular el promedio antes de poder comparar cualquier precio individual. Incruste la función PROMEDIO dentro de otra función para calcular primero el promedio.

Funciones de anidamiento.

Cuando una función está anidada dentro de otra, la función interna se calcula primero. Entonces ese resultado se usa como argumento para la función externa.

La función COUNTIF cuenta el número de células en un rango que cumplen una condición. La condición en este caso es que cualquier valor individual en el rango sea mayor que (>) el promedio del rango. La fórmula en la celda D7 es =COUNTIF(B5:B25, «>» y PROMEDIO(B5:B25)). Primero se evalúa la función PROMEDIO; luego se evalúa la función CONTAR, utilizando como argumento el valor devuelto de la función anidada.

Las funciones anidadas se introducen mejor directamente. El cuadro de diálogo Insertar función no facilita la introducción de una función anidada. Prueba con uno. En este ejemplo, se utiliza la función PROMEDIO para encontrar el promedio de los valores máximos de dos conjuntos de números. La función anidada en este ejemplo es MAX. La función MAX se introduce dos veces en la función PROMEDIO. Siga estos pasos:

  1. Introduzca algunos números diferentes en una columna.
  2. Introduzca algunos números diferentes en una columna diferente.
  3. Haga clic en una celda vacía donde desea que aparezca el resultado.
  4. Escriba =AVERAGE( para iniciar la entrada de la función.
  5. Tipo MAX(.
  6. Haga clic en la primera celda del segundo grupo de números, pulse el botón del ratón y arrastre sobre todas las celdas del primer grupo.
  7. Introduzca un paréntesis de cierre para finalizar la primera función MAX.
  8. Introduzca una coma (,).
  9. Una vez más, escriba MAX(.
  10. Haga clic en la primera celda del segundo grupo de números, pulse el botón del ratón y arrastre sobre todas las celdas del segundo grupo.
  11. Introduzca un paréntesis de cierre para finalizar la segunda función MAX.
  12. Introduzca a ), con lo que finaliza la función PROMEDIO.
  13. Pulse Intro.

Esta figura muestra el resultado de su función anidada. La celda C14 tiene esta fórmula: =PROMEDIO(MAX(B4:B10),MAX(D4:D10)).

Obtener un resultado de funciones anidadas.

Cuando se utilizan funciones anidadas, la función exterior va precedida de un signo igual (=) si es el principio de la fórmula. Las funciones anidadas no van precedidas de un signo igual.

Puede anidar funciones de hasta 64 niveles.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *