Trabajar con funciones IF en Excel 2016

  1. Software
  2. Oficina de Microsoft
  3. Excel
  4. Trabajar con funciones IF en Excel 2016

Libro Relacionado

Por Faithe Wempen

La función SI de Excel intimida a mucha gente, pero no es tan difícil conceptualmente. La función IF determina si una afirmación es verdadera o falsa, y luego toma una de dos acciones dependiendo de la respuesta.

Veamos un ejemplo en inglés sencillo. Supongamos que cuando la suma de C2 y D2 es mayor que 100, se desea mostrar en E2 el resultado de multiplicar la suma de C2 y D2 por 0.05. Por otro lado, cuando C2+D2 no es superior a 100, E2 debería mostrar 0.

La sintaxis de la función IF es:

=IF(condición,valor_si_verdadero,valor_si_falso)

Así que primero escribamos la condición:

C2+D2>100

Si la condición es verdadera queremos hacer esta matemática para el valor_if_true :

(C2+D2)*0,05

Observe que hay paréntesis alrededor de la operación de suma. Sin estos paréntesis, no se haría primero; en el orden de las operaciones, la multiplicación viene antes que la suma.

La tercera parte de la función, el valor_if_false, es 0.

Rellenando estos valores en la función, se ve así:

=SI(C2+D2>100,(C2+D2)*0.05,0)

Si tiene más de dos condiciones posibles y desea algo diferente para cada una de ellas, puede anidar una función IF dentro de otra. Puede manejar dos de las condiciones en el IF interno y luego aplicar la tercera condición en el IF externo.

Aquí hay un ejemplo a seguir. Supongamos que queremos mostrar algún texto según el valor de C2+D2. Cuando C2+D2 es superior a 100, queremos mostrar el texto «Bueno» y cuando C2+D2 es superior a 50 pero inferior a 100, queremos mostrar el texto «Justo». Cuando ninguna de esas condiciones es cierta, queremos mostrar el texto «Pobre».

Empezamos evaluando la primera condición como el valor_if_true:

=IF(C2+D2>100,"Bueno")

El valor_if_false será otra instrucción IF:

=IF(C2+D2>50,"Regular","Pobre")

Ponerlos juntos – omitir el signo = para la función anidada – tiene el siguiente aspecto:

=IF(C2+D2>100,"Bueno",IF(C2+D2>50,"Regular","Pobre"))

Observe los tres paréntesis de cierre al final, uno para cada FI.

Ahora que sabe cómo funcionan las funciones IF, puede encadenar tantos niveles de anidamiento como necesite para realizar el trabajo.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *